Jump to content

Bug - Garrison recruits


Recommended Posts


At the end of Act 1 I had an empty space to hire a praetorian. I rerolled a bunch of times until I saw just the guy I needed. I tried to hire him, but the game would hire a random praetorian that I had fired before. I tried many times but I just couldn't hire a new guy even though the option was here. Now in Act 2 the garrison looks like this. I can't see anything from the second column and if I try to  hire that Triarius with <Missing string> it's going to hire the Princeps on the top right. 

  • Sad 1
Link to comment
Share on other sites

  • 2 weeks later...

I also experienced this.

Additionally I had an issue where this character corruption issue occured when my character was assigned to the garrison for recruitment during the Egypt campaign.

My game had some sort of glitch where it simultaneously treated him as unassigned from the garrison (not visible in the outpost assignment screen) but also assigned to the garrison in all the other menus (inventory, garrison party screen and selection for encounters).

This meant I could never bring him into any engagement and could also never dismiss him from my Praetorians. In larger scale battles this prevented me from bringing my full set of praetorians to the encounter.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...